Unable to start Jaspersoft services and getting Access denied
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Unable to start Jaspersoft services and getting Access denied

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Article ID: 231384

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Unable to start Jaspersoft services and the below errors are thrown in catalina.out

java.io.FileNotFoundException: /apps/tomcat/apache-tomcat-9.0.37/webapps/reportservice/WEB-INF/logs/jasperserver.log (Permission denied) java.io.FileNotFoundException: /apps/tomcat/apache-tomcat-9.0.37/webapps/reportservice/WEB-INF/logs/jasperserver.log (Permission denied)

Or

java.io.FileNotFoundException: $apache-tomcat-9.0.62\webapps\reportservice\WEB-INF\logs\jasperserver.log (Access is denied) 

 

Environment

Release : Any Supported Jaspersoft release

Cause

This is due to lack of permissions for Jaspersoft Logs folders 

Resolution

  • Check which is the user starting Jaspersoft
  • Ensure to provide Full access to the below folders for any Jaspersoft installation 
    • $Jasper_home\work
    • $Jasper_home\logs
    • $Jasper_home\reportservice\WEB-INF\logs