Notification Error
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Notification Error

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Article ID: 231374

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Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

The notification utility is not working at the new broker.  Below are screenshots. 

Environment

Release : 14.0+

Component : CA HARVEST SCM CORE FUNCTIONALITY/PROCESS AUTOMATION

Cause

The mail command is picking up the Harvest version of libcrypto.so instead of the system version and there is a conflict.

Resolution

We suggest the following workaround to force the mail command and the mailx command to use the proper libraries:
 
Login with the harvest userid and cd to your $CA_SCM_HOME/bin folder.

1. The first thing is to find the folder containing the 64-bit version of "libk5crypto.so.3" (from the error message).  We will need to add that folder to the path before running mail or mailx

For example:

[<userid>@<hostname> bin]$ find / -name libk5crypto.so.3 2>/dev/null
/usr/lib/libk5crypto.so.3
/usr/lib64/libk5crypto.so.3

2. Create a file named “mailx” (or "mail" if you prefer) and add these lines to it:

#!/bin/bash
export LD_LIBRARY_PATH=/usr/lib64:$LD_LIBRARY_PATH  # <--- folder containing libk5crypto.so.3
/usr/bin/mailx "$@"   # or "/usr/bin/mail" if you prefer
# end of script

3. Save and close this file and set the permissions to be executable with this command:

chmod a+x mailx   # or mail if you prefer

4. In your notification UDPs make sure that you prefix the mailx command with the location of the script.  For example:

For regular UDP notifications in Harvest this is all that is needed.  If you are using the Peer Review feature and need to configure the "-premail=" option in HServer edit the /opt/CA/scm/HServer.arg file with vi or your favorite editor and add a line that looks like this:

-premail="/opt/CA/scm/bin/mailx -r [email protected]"

(The email address you specify for the "-r" option is the "from" email address for your message)

After editing HServer.arg you will need to save and close the file, and then stop and restart the SCM Broker process.

 

Additional Information

If the above does not resolve the problem completely, you should also check the user's .profile or .bash_profile to ensure that all Harvest-related folders are listed at the beginning of the PATH and LD_LIBRARY_PATH environment variables.  If you make any changes, please be sure to re-source the profile and restart the broker.