EEM portal does not load after updating the LDAP UserStore
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EEM portal does not load after updating the LDAP UserStore

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Article ID: 231328

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

The EEM portal does not load after configuring the LDAP UserStore. The $EIAM_HOME/logs/server.log has the following message captured -
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] GenericConnector::getInfo: error acquiring ldap connection [userstore: Domain]
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] Exception[-800]: failed to create ldap connection
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] [src/LdapConnector.cpp:209] eiam::server::ldap::LdapConnection* eiam::server::ldap::LdapConnector::newConnection(bool)
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] [src/LdapConnector.cpp:242] eiam::server::ldap::LdapConnection* eiam::server::ldap::LdapConnector::acquireConnection()
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] Caused by:
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] Exception[-800]: bind failed
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] [src/LdapUtil.cpp:365] LDAP* eiam::server::ldap::LdapUtil::newLdapConnection(const eiam::core::String&, const eiam::core::String&, const eiam::core::String&)
ERROR 2021-12-29 04:00:47,820 [0x2b7509409700] [eiam.server.userstore.genericconnector] [src/LdapUtil.cpp:269] eiam::server::ldap::LdapConnection* eiam::server::ldap::LdapUtil::newConnection(const eiam::core::String&, const eiam::core::String&, const eiam::core::String&)

Environment

Release : 12.51 and higher

Component :

Cause

The LDAP bind failure is due to incorrect LDAP connection information provided.

Resolution

Stop igateway service

Backup the file $EIAM_HOME/config/server/server.xml

Open the original file in edit mode and find the tag <userstores>

<userstores>

    <genericldapstore name="Domain">

      <map>Microsoft Active Directory</map>

      <hostname>10.0.1.2:3268</hostname>

      <basedn>CN=AE,DC=ATSYS,DC=COM</basedn>

      <userdn>CN=test connection,CN=AE,DC=ATSYS,DC=COM</userdn>

      <password>{MUNGE2}ARoAFUhgfyVYU14=</password>

      <maxbindconnections>3</maxbindconnections>

      <maxconnections>10</maxconnections>

      <conntimeout>20</conntimeout>

      <requesttimeout>60</requesttimeout>

      <searchretrycount>3</searchretrycount>

      <pagesize>1000</pagesize>

      <paged>false</paged>

      <ldapautoreferral>false</ldapautoreferral>

      <security enabled="false">

        <mode>tls</mode>

        <certfile></certfile>

        <keyfile></keyfile>

        <cacertfile></cacertfile>

      </security>

      <domain></domain>

    </genericldapstore>

  </userstores>

All the details provided here are in clear text except for the password.

Verify the hostname and port information are correct and they are reachable over the network from the EEM server(PING/telnet)

Verify the BaseDN and userDN specified.

Correct the information as required and restart the service.

If you want to revert to EEM internal UserStore replace the content between <userstores>...</userstores> with the following -

<userstores>

        <internaldirectory name="internaluserstore">

            <map>internaluserstore</map>

            <basedn>cn=Users,cn=Entities,cn=iTechPoz</basedn>

            <maxbindconnections>5</maxbindconnections>

            <maxconnections>10</maxconnections>

            <conntimeout>20</conntimeout>

            <requesttimeout>60</requesttimeout>

            <searchretrycount>1</searchretrycount>

            <pagesize>2000</pagesize>

            <paged>true</paged>

            <ldapautoreferral>false</ldapautoreferral>

            <security enabled="true">

                <mode>tls</mode>

                <certfile></certfile>

                <keyfile></keyfile>

                <cacertfile></cacertfile>

            </security>

            <domain></domain>

        </internaldirectory>

    </userstores>

Restart the EEM igateway service.