Unable to logout after persistent session times out
search cancel

Unable to logout after persistent session times out

book

Article ID: 231309

calendar_today

Updated On:

Products

SITEMINDER

Issue/Introduction

 

If a user's session exceeds the idle timeout threshold and then the user attempts to log out, the user's browser receives a 500 error.

Error in webagent trace logs:

[03/09/2021][10:19:09][58116][2759788288][CSmLowLevelAgent.cpp:3434][LogoutSession][00000000000000000000000059e0810b-e304-60473d8d-a47f0700-14fb2a5b1ef0][*29.136.11.137][][ukd006_ihcm][/][rBNEWTON_FIT3][Calling LogoutSession for session 'OfxOjbz0fmxVThzw7XSlsgOBsYs='.]
[03/09/2021][10:19:09][58116][2759788288][CSmLowLevelAgent.cpp:4560][LogoutSession][][][][][][][Session not logged out.]
[03/09/2021][10:19:09][58116][2759788288][CSmSessionManager.cpp:167][CSmSessionManager::EstablishSession][00000000000000000000000059e0810b-e304-60473d8d-a47f0700-14fb2a5b1ef0][*29.136.11.137][][ukd006_ihcm][/][rBNEWTON_FIT3][LowLevelAgent was unable to logout session.]

 

Cause

 

This is a defect. Since the user does not have a valid session, indeed, the session could not be logged out, but it is also true that the user has no proper session, and that's the state the user is requesting, thus, an appropriate message should be returned rather than a 500 error.

 

Resolution

 

Upgrade the Policy Server to 12.8SP7 to fix this issue (1).

 

Additional Information

 

(1)

    Defects Fixed in 12.8.07

      | Salesforce Case Number | Internal Defect ID | Issue Description               |
      |------------------------+--------------------+---------------------------------|
      | 32649263, 33157671     | DE511328           | An FCC-based logout results in  |
      |                        |                    | HTTPS 500 error when it is      |
      |                        |                    | accessed by a user with a timed |
      |                        |                    | out persistent session.         |