Unable to log out after persistent session timeout in Policy Server
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Unable to log out after persistent session timeout in Policy Server

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Article ID: 231309

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Updated On:

Products

SITEMINDER CA Single Sign-On

Issue/Introduction

If a user's session exceeds the idle timeout threshold and then the user attempts to log out, the user's browser receives a 500 error.

Error in the Web Agent trace logs:

[03/09/2021][10:19:09][58116][2759788288][CSmLowLevelAgent.cpp:3434][LogoutSession][][*10.0.0.1][][<agent>][/][][Calling LogoutSession for session '<value>'.]
[03/09/2021][10:19:09][58116][2759788288][CSmLowLevelAgent.cpp:4560][LogoutSession][][][][][][][Session not logged out.]
[03/09/2021][10:19:09][58116][2759788288][CSmSessionManager.cpp:167][CSmSessionManager::EstablishSession][][*10.0.0.1][][<agent>][/][][LowLevelAgent was unable to logout session.]

Cause

This is a defect fixed in Policy Server 12.8SP7, fix number DE511328 (1).

Since the user does not have a valid session, indeed, the session could not be logged out, but it is also true that the user has no proper session, and that's the state the user is requesting, thus, an appropriate message should be returned rather than a 500 error.

Resolution

Upgrade the Policy Server to 12.8SP7 to fix this issue.

Additional Information