Unable to login to OAuth Manger after OTK Toolkit 4.4 Upgrade
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Unable to login to OAuth Manger after OTK Toolkit 4.4 Upgrade

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Article ID: 231221

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Updated On:

Products

CA API Gateway

Issue/Introduction

After upgrading to the OTK 4.4 toolkit, accessing the OAuth manager results in this error: 


Gateway log shows:

 INFO    385 com.l7tech.server.policy.assertion.ServerAuditDetailAssertion: -4: No id_token lookup could be executed
 INFO    385 com.l7tech.external.assertions.jdbcquery.server.ServerJdbcQueryAssertion: 9105: "Perform JDBC Query" assertion failed due to no query results via a connection OAuth
 WARNING 385 com.l7tech.server.policy.assertion.composite.ServerHandleErrorsAssertion: 11000: Policy processing caught an exception: RaiseErrorAssertion is stopping execution.
 INFO    385 com.l7tech.external.assertions.comparison.server.ServerComparisonAssertion: 7101: Comparison did not match: ${isCached} is equal to true
 INFO    385 com.l7tech.server.policy.assertion.ServerAuditDetailAssertion: -4: error.code: '000', error.msg: {
  "error":"invalid_request",
  "error_description":"The request failed due to some unknown reason"
}
 INFO    385 com.l7tech.external.assertions.comparison.server.ServerComparisonAssertion: 7103: At least one comparison value was null
 INFO    385 com.l7tech.server.MessageProcessor: 3017: Policy evaluation for service oauth/manager [e001cfd0c1cedited18e187b5eedited4e] resulted in status 600 (Assertion Falsified)
 WARNING 385 com.l7tech.server.message: Message was not processed: Assertion Falsified (600)

 

Environment

API Gateway

OTK

Cause

Custom firewall rule on port 7443 was the cause for this upgrade failure

Resolution

Disabling the custom firewall rule for the port 7443 on the listen port properties (in policy manager) resolved this issue.