Symantec Management Agent service fail to start and does not upgrade or uninstall
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Symantec Management Agent service fail to start and does not upgrade or uninstall

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Article ID: 231129

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Updated On:

Products

IT Management Suite

Issue/Introduction

Symantec management Agent (SMA) on some computers does not get upgraded to the latest version. 

Checked the 'Symantec Management Service' and it failed to start.

Tried to uninstall the agent as per the following article, but it failed:  Instructions for the complete manual uninstall of the Altiris agent

 

Errors and Warning in the agent logs:

  • Action RunCmd: file 'C:\Windows\system32\inetsrv\appcmd.exe' does not exist.
  • Failed to unregister type library '2' for module 'C:\Program Files\Altiris\Altiris Agent\AeXNetMon.dll', error: Error accessing the OLE registry (0x8002801C)
  • Cannot delete file 'C:\Users\USER~1\AppData\Local\Temp\AeX_{098575C4-2277-471E-A413-7334B173CF4F}_11892.tmp\AeXNSAgentInst.exe', error: Access is denied
  • Failed to initialize agent storage: The specified module could not be found (0x0000007E)
  • Signature generation failed, error: The specified module could not be found

Environment

ITMS 8.x

Cause

SEP agent (Symantec Endpoint Protection) didn't have the settings that was defined in the manager for the group policies and it does not updated the configurations.

Also SEP was not upgraded on the agent and that was not allowing the Symantec agent to be upgraded or uninstalled. 

Resolution

  1. Uninstall and reinstall the SEP Agent on the system and Reboot the computer.
  2. Check the service 'Symantec Management Agent' and make sure it starts and the status is running.
  3. Now the Symantec Management Agent can receive the upgrade policy. You can also uninstall and reinstall it.

 

Additional Information