Cabi-Jaspersoft Reporting Wrong Data showing up in Spectrum based reports
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Cabi-Jaspersoft Reporting Wrong Data showing up in Spectrum based reports

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Article ID: 231101

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Updated On:

Products

CA Spectrum

Issue/Introduction


When we run Spectrum-based data reports (e.g., Top-N Least Available: Group), the output of the report are inaccurate. The results are either 100% or 0%. Could you please check and advise ?


Environment

Release :Spectrum 10.4.x, 21.x

Component : Spectrum Reporting

Cause

Reports are needed to be redeployed with the latest spectrumConfigInstaller.jar file.

Resolution

Please redeploy the reports and please follow the below steps to verify the report again.

1. Stop JasperServer
2. Move the existing SpectrumProxy.war and SpectrumProxy  to another folder outside of the  CABI install location.
3. Login to OneClick Admin page and navigate to 
   Administrator -> Reportmanager -> Jasper Integration Page
4. Download the latest spectrumConfigInstaller.jar into Jasper Server (Integration components) 
5. Copy these files back into the location from step 2.  Then run the downloaded Jar file as 
   java -jar spectrumConfigInstaller.jar -install
5. Start Jasper Server
6. Once the Jasper is up and running, do 'Re-deploy' from Jasper Integration page.
7. Verify that JasperServer is up and running and able to run reports.