sdgtw getting a 500 error when the UIM alarm is acknowledged/cleared and the probe attempts to resolve the ticket in Remedy.
search cancel

sdgtw getting a 500 error when the UIM alarm is acknowledged/cleared and the probe attempts to resolve the ticket in Remedy.

book

Article ID: 231068

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

sdgtw probe - getting a 500 error in the probe log when the UIM alarm is acknowledged/cleared and the probe attempts to resolve the ticket in Remedy. 

sdgtw probe excerpt with loglevel set to 4 for alarm id RG05221965-04756

[pool-50-thread-2, sdgtw] :: Going to get output stream on this connection ::
[pool-50-thread-2, sdgtw] responseCode :: [500] response message :: [Internal Server Error]
[pool-50-thread-2, sdgtw] Error while calling the resolve incident  of 'nimClient'java.lang.Exception: {"Error":{"ErrorCode":154,"ErrorMessage":"Exception occurred during operation Update SD Object","DetailErrorMessage":"ERROR (341): Set Fields process failed.; ERROR:  Operation failed. HTTP Status: 400 (Bad Request).\r\n\r\nThe ID 'RG05221965-04756' is not a valid

Environment

Release : 20.3

Component : UIM - SDGTW

Cause

Missing configuration on the Remedy side for UIM Integration

Resolution

This issue was confirmed to be on the Remedy side, as the same error was reproduced when manually resolving a ticket in Remedy.
Contact the Remedy admin to review the ticket requirements closures and accommodate required changes on the Remedy side