How do I customize login.fcc in Access Gateway configuration
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How do I customize login.fcc in Access Gateway configuration

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Article ID: 231065

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Updated On:

Products

SITEMINDER CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction

Is there a way to use a custom login.fcc file for the authentication scheme on SiteMinder Access Gateway?

Environment

Release : 12.8.07

Component : SITEMINDER SECURE PROXY SERVER

Cause

Yes, this can be accomplished by some minor changes, and customization result depends on ACO Localization value.

Resolution

When Localization is commented out on the ACO, it will take the default value as localization=Yes.

Assuming the locale is en-US, then it will pick the content from folder 

C:\Program Files\CA\secure-proxy\proxy-engine\examples\siteminderagent/forms_en-US/login_en-US.fcc

The doc link below explain more on how Localization works.

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/siteminder/12-8/configuring/web-agent-configuration/fcc-internationalization.html

If conduct a quick modification of the file content, then it will display the change.

The log confirms the loading location as well.

[12/15/2021][19:40:28][3776][4232][24754760-f7fa8c8c-6d6a68a1-68aeb7a6-de8652e1-e9b][SmFcc::getLocalePath][Localized Path = C:\Program Files\CA\secure-proxy\proxy-engine\examples\siteminderagent/forms_en-US/login_en-US.fcc, working locale = en-US]
[12/15/2021][19:40:28][3776][4232][][CSmFormTemplateCache::GetForm][Form template 'C:\Program Files\CA\secure-proxy\proxy-engine\examples\siteminderagent/forms_en-US/login_en-US.fcc' not found in cache.]
[12/15/2021][19:40:28][3776][4232][][CSmFormTemplateCache::GetForm][Serving form template 'C:\Program Files\CA\secure-proxy\proxy-engine\examples\siteminderagent/forms_en-US/login_en-US.fcc' from disk.]
[12/15/2021][19:40:28][3776][4232][][CSmFormTemplateCache::GetForm][Form template 'C:\Program Files\CA\secure-proxy\proxy-engine\examples\siteminderagent/forms_en-US/login_en-US.fcc' stored in cache.]

Please be aware, Access Gateway may require a stop/start service, and remove old login_en-US.fcc file out of folder, to avoid cache interference.

If Localization=no, this will revert agent to behave like agent versions prior to 12.51.  Disabling agent internationalization prevents the use of all forms supplied with the new agent and disables all other agent internationalization features. For a long term solution, we recommend migrating your existing FCCs to work on an internationalized agent and reenabling agent internationalization.

Additional Information

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/siteminder/12-8/configuring/web-agent-configuration/fcc-internationalization.html