Connection Refused when accessing Rally through a Channel
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Connection Refused when accessing Rally through a Channel

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Article ID: 231055

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Clarity users cannot access Rally (or any 3rd party application) directly from Clarity when Rally is configured as a Clarity Channel in SSO authentication environments in Clarity SaaS GCP.  This issue is limited to SSO environments and it is Clarity SSO or the target application SSO that causes this issue.

STEPS TO REPRODUCE: 

  1. In Clarity create a Blueprint with a Channel using the following configuration
    • Channel Name - Rally
    • Channel URL - https://rally1.rallydev.com/#/*ID*/timeline?view=*ID*(for example)
  2. Access a Project that has the template, and click the Rally module.

Expected Results: When you haven't logged into Rally in the browser and connected to Rally via a Channel in the same browser at the same time, you should be presented with the Rally login screen, if Rally is non SSO else there should be seamless login to Rally 

Actual Results: When attempting to access Rally using a Clarity Channel and a Rally session has not been established, authentication to login.broadcom.com may fail and the user will receive a 'Connection Refused' error

  • The following shows in Firefox as the problem: To protect your security, login.broadcom.com will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window. Once logged into Rally in the browser, the Channel login renders correctly on SSO environments in Edge, Chrome, and Firefox. In the future, any attempt to connect to Rally via the Channel is successful till the session is active in browser.

Environment

Release : All supported Clarity version with Rally SaaS 

Component : Clarity MUX UI Usability

Cause

  • The issue is because the page(login.broadcom.com) has x-frame-option set as  "same origin"(please see the snapshot attached). This essentially means the page will not open in an i-frame and all channels in our clarity open in i-frame. This is a security setting at Broadcom Portal to now allow Iframe embedding to avoid susceptible to clickjacking  and in channel clarity uses Iframe embedding.
  • This was logged as defect DE63535 and further work in under way to enhance the channel functionality using SSO 

Resolution

WORKAROUND: 

  • Option 1: Open a new browser tab, and log into Rally. Once authenticated, then you should be able to access Rally through a "Channel".
  • Option 2: Use the "Links" option instead of Channels.

There are plans to expand the functionality in a future release of Clarity.

Additional Information

Documentation - https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/clarity-project-and-portfolio-management-ppm-on-premise/16-0-0/release-information/clarity-ppm-release-notes.html#concept.dita_8ebed6ba1fc5de89d746baa8a9be14ef035caa38_RallyChannel