Alerting Rules in Unijob stop working with received wrong message
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Alerting Rules in Unijob stop working with received wrong message

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Article ID: 231049

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Some Alerting Rules are defined for Unijob nodes and suddenly UVMS stops sending email for Alerts that should have generated the email (ie. long running jobs or jobs in a supervised status).

Example of the alerting rules enabled on a particular Unijob node:

The following kind of error message is displayed in unijob.log when alert should have been triggered:

 |ERROR|IO |pid=p.t| u_io_decode_alert_rep     | received wrong message(300312002021121511064500002R000001*001*001*019)

 

Environment

Release : 1.4.5

Component : UNIJOB

UVMS in version 6.10.91

Cause

Most likely a bug in Unijob.

Resolution

Workaround:

Disable or Delete any Unijob Alerting Rule with "Maximum Duration" as Filter.

Solution:

Migrate Unijob Nodes to Dollar Universe Runtime license nodes as Unijob is in End of Life/Support since 2016.

This operation has no costs transferring the licenses from Unijob to Dollar Universe Runtime nodes.

Migration can be done graphically via UVC, for more assistance, please reach out to your Account Director.