Ticket Not Creating in Service Catalog SSL Environment
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Ticket Not Creating in Service Catalog SSL Environment

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Article ID: 231035

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog

Issue/Introduction

Customer is trying to create a ticket in Service Catalog.

After the fields are filled and the Create Ticket button is clicked nothing happens.

Environment

Release : 17.3

Component : Catalog - SSL/HTTPS Issue

Cause

In Developer Mode, we see the following error:

The censored portion contains the URL for Service Catalog.

Resolution

Verify the web.xml under

<filter>
  <filter-name>CorsFilter</filter-name>
  <filter-class>org.apache.catalina.filters.CorsFilter</filter-class>
  <init-param>
    <param-name>cors.allowed.origins</param-name>
    <param-value> "VERIFY CORRECT URL HERE"</param-value>
  </init-param>
  <init-param>

 

Additional Information

web.xml Default Location

USM_HOME%\view\webapps\usm\WEB-INF

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