Error: Failed DD Reference for an Attribute EnableIdentityMapping
search cancel

Error: Failed DD Reference for an Attribute EnableIdentityMapping

book

Article ID: 230966

calendar_today

Updated On:

Products

CA Single Sign On Agents (SiteMinder) SITEMINDER

Issue/Introduction

An issue occurs when saving new or modifying existing partnerships in the AdminUI.

In logs, this message shows up:

[ERROR] com.ca.federation.adminui.backingbean.federation.PartnershipListBean [] - **ERROR** com.ca.fedxps.api.remote.FedXPSException during UI operation.
com.ca.fedxps.api.remote.FedXPSException: com.ca.federation.client.XPSException: Failed to get the DD Reference for an Attribute, Attr = CA.FED::PartnershipBase.EnableIdentityMapping, Vendor = CA, Prod = FED, Class = PartnershipBase : CA : XPS : sm-xpssvc-00140
at com.ca.fedxps.api.remote.FedXPSObjectStore.update(Unknown Source) ~[fedremoteapi.jar:?]

This message indicates that the Data Definition for this object is missing or incorrect.

The standard solution is to reimport the DD files again, in this case, it would be the FedObjects.xdd (1).

However, in this case, importing the FedObjects.xdd or the SmMaster.xdd did not resolve or change the error in any way.

Environment

Policy Server is on one version;

AdminUI is on another version, different from the Policy Server.

Cause

It was noticed that the AdminUI was reporting a version mismatch.

The AdminUI was on one version whereas the Policy Server was on a lower version.

This meant the Policy Store, base objects, and Data Definitions would also be at the Policy Server version.

In the AdminUI, when creating a Partnership, after adding to the User directory, the Enable Identity Mapping checkbox would appear.

However, when looking in XPSExplorer under FED, PartnershipBase, this attribute can't be seen.

For comparison purposes, check the same steps on a AdminUI the same version as the Policy Server, the checkbox did not appear after adding the User Directory.

This meant that the Enable Identity Mapping was new to later version and did not exist in the former version, which is why the AdminUI could not save that setting, preventing the partnership itself from being saved.

Resolution

The solution is to either:

  • Upgrade the Policy Server and Stores to the AdminUI version so they would have the newer Data Definitions imported, which would have the missing attribute needed to save the value of the Enable Identity Mapping checkbox;
  • Downgrade the AdminUI to the Policy Server version so that the feature set the UI is using matches the Data Definitions of the Policy Store, meaning no Enable Identity Mapping checkbox in this specific case.

Additional Information