MUX is not redirected properly when the session times out in Clarity
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MUX is not redirected properly when the session times out in Clarity

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Article ID: 230893

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

An SSO configured Clarity Modern User Experience (UX / MUX) requires the SAML_ENABLED option even if SAML is not enabled. When the Clarity session times out, the Modern UX doesn't redirect properly unless SAML_ENABLED=1 is in the system options. 

Steps to Reproduce: 

  1. Configure Clarity for SSO and set the SAML_ENABLED system option to 1 even though you don't send SAML to Clarity.
  2. Use AWS Incognito for SAML support
  3. Have your Clarity use the 'legacy' way of supporting SSO, i.e., without SAML.  

Expected Results: The intent of the SAML_ENABLED system option was to determine how the SAMLFilter was to be used. It' use outside should be limited and not necessary for sending the logoutURL and errorURL to the client. 

Actual Results: The Modern UX is not redirected properly when the Clarity session times out. 

Environment

Clarity Release: 15.9.3

Cause

DE62744  

Workaround: SAML_ENABLED must be set to 1. 

Resolution

  • Fixed in Release 16.0.0 
  • Fixed in Release 15.9.3 Patch #2 (15.9.3.2) 

Additional Information