DLP Flexresponse integration returns 500 response after upgrade to 10.7.5
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DLP Flexresponse integration returns 500 response after upgrade to 10.7.5

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Article ID: 230860

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Following the upgrade of Messaging Gateway (SMG) to version 10.7.5 attempts to remediate incidents in DLP via the Flexresponse plugin return the following error:

Input error when reading response from email gateway: java.io.IOException: Server returned HTTP response code: 
500 for URL: https://smg.domain.com:8443/brightmail/ws/DlpQuarantineActionsService

Environment

Release : 10.7.5

Component : DLP Flexresponse API

Cause

This issue is currently under investigation but appears to be associated with x509 extensions in the client certificate used for API authentication.

Resolution

Workaround

  • Remove the existing client certificate from the DLP server and the SMG control center Administration > Certificates > Applications page
  • Create a new client certificate with no x509 extensions and a simple Subject:. The certificate can be self signed.
  • Add the new client certificate to the DLP server keystore and to the SMG Administration > Certificates > Applications page
  • Restart the SMG appliance / virtual machine or restart the control center web application by running the following from the admin command line:
    service controlcenter restart

A simplified and updated client certificate should resolve the API authentication issues. If you continue to see errors from the DLP Flexresponse API, please contact Messaging Gateway support.