Events in Spectrum Report Manager (SRM) are updating slower for one landscape than others.
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Events in Spectrum Report Manager (SRM) are updating slower for one landscape than others.

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Article ID: 230823

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The "last event time" is not updating in the SRM or report manager processing is slow / behind:

This SRM is monitoring 2 landscapes, and the event time is not updating for just one of the landscapes.

Working landscape:

mysql> select MAX(time), hex(landscape_h) from event where hex(landscape_h)='A000000';
+---------------------+------------------+
| MAX(time)           | hex(landscape_h) |
+---------------------+------------------+
| 2022-05-17 12:44:42 | A000000          |
+---------------------+------------------+

 

On the non-working landscape: - (Last updated on 5th Dec)

mysql> select MAX(time), hex(landscape_h) from event where hex(landscape_h)='B000000';

+---------------------+------------------+

| MAX(time)           | hex(landscape_h) |

+---------------------+------------------+

| 2021-12-05 15:45:39 | B000000          |

+---------------------+------------------+ 

Environment

Release : Any

Component : Spectrum Reporting

Cause

The non-working landscape has a very large number of events in the Archive Manager (DDM) database to log. By default, only 10007 events at a time are sent from the DDM database to the SRM reporting database.

Resolution

On the non-working landscape, edit the file:

$SPECROOT/SS/DDM/.configrc

Add the following parameter:

record_search_limit=50000

Save the file. Then, restart the Archive Manager (ArchMgr) process for the change to take affect.

NOTE: remember to set the parameter back to "10007" once the bulk sync is completed, else you may experience other performance issues later on.