Broadcom API Gateway - MySQL log show repeated entries of "ERROR 1045 (28000): Access denied for user '<repluser?'@'<gatewayhostname>' (using password: YES)" despite the replication works fine
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Broadcom API Gateway - MySQL log show repeated entries of "ERROR 1045 (28000): Access denied for user '<repluser?'@'<gatewayhostname>' (using password: YES)" despite the replication works fine

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Article ID: 230695

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Updated On:

Products

CA API Gateway

Issue/Introduction

Case scenario: We have correctly followed steps to update MySQL user "<repluser>" password and the replication is working just fine. 

However, upon reviewing /var/log/mysqld.log log file, we discovered a repeated error (occurring every night at same time) :

ERROR 1045 (28000): Access denied for user '<repluser>'@'<gatewayhostname>' (using password: YES)

Environment

API Gateway 9.x/10.x 

Cause

If the password was correctly updated and the replication is not broken, the above error likely means that the old <repluser 's> password still used somewhere else.

Resolution

The fact that the error occurrence is every night at same time, it usually leads investigation to a scheduled task.

On the product side, a possible root cause is the implementation of automated (cronjob) SQL binary log maintenance via Manage Binlogs script.

Post updating repluser password in MySQL, the new password needs also to be changed in the manage_binlogs.sh script configuration, under the following section:

If you are overriding the password using -p option directly in the cronjob (it can be checked by executing crontab -l command),  please update the cronjob:

In that case, please run crontab -e and change the old password with the new one