search cancel

Location of the Harvest log files

book

Article ID: 230571

calendar_today

Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

Depending on which Harvest component is encountering a problem, the log file that will provide the needed information to diagnose the issue will be found in a component-specific location with its own naming convention and contents.  What follows is a list of "where to look" for the log files you need.

Environment

CA Harvest Software Change Manager all versions and components

Resolution

Server-Side

  • SCM Broker
    • logging settings go in %CA_SCM_HOME%\HBroker.arg
    • change in the arg file requires restart to take effect
    • can dynamically turn on/off and set logging levels using hdbgctrl command line utility
    • log files found in %CA_SCM_HOME%\log
    • log file name format: <yyyymmdd>HBroker<pid>.log
    • at midnight each day logging rolls to a new log file
    • options available

-qtrace

Turns on the trace for the broker maintained queues and tables. When this option is specified, it directs the contents of the broker maintained queues and tables to the broker log file (or to the stdout if -verbose is specified) whenever the queues or tables are modified.

-trace

Displays PEC-related trace messages.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/harvest-scm/14-0/installing/Configure-CA-Harvest-SCM/Configure-Broker-and-Server-Communication/Configure-the-Broker-and-Server-Communication-on-Windows.html (section titled “Broker Options on Windows”)

 

  • SCM HServer
    • logging settings go in %CA_SCM_HOME%\HServer.arg
    • change in the arg file requires restart to take effect
    • can dynamically turn on/off and set logging levels using hdbgctrl command line utility
    • log files found in
      • default: %CA_SCM_HOME%\log
      • check the “-homedir” and/or “-homeserver” settings in %CA_SCM_HOME%\HBroker.arg for location
    • log file name format: <yyyymmdd>HServer<pid>.log
    • at midnight each day logging rolls to a new log file
    • options available

-logging=int

Writes detailed server information to the server log. Each log level displays the information of all levels below it. The levels are cumulative not mutually exclusive.

1

displays ODBC errors and any error messages written by the relational database.

2

displays the product Transaction name; the date and time it started; the date and time it ended; the name of the server and process ID that processed the transaction; and the duration of the transaction in milliseconds.

3

displays the executed SQL statement, when it started, when it ended, the execution time in milliseconds, and the time in milliseconds since the last completed SQL.

4

displays commit and rollback statements.

5

displays the results of the SQL statements being executed.

-trace

Displays PEC-related trace messages.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/harvest-scm/14-0/installing/Configure-CA-Harvest-SCM/Configure-Broker-and-Server-Communication/Configure-the-Broker-and-Server-Communication-on-Windows.html (section titled “Server Options on Windows”)

 

  • SCM Agent
    • logging settings go in %CA_SCM_HOME%\HAgent.arg
    • change in the arg file requires restart to take effect
    • can dynamically turn on/off and set logging levels using hdbgctrl command line utility
    • log files found in %CA_SCM_HOME%\log
    • log file name format: <yyyymmdd>HAgent<pid>.log
    • at midnight each day logging rolls to a new log file
    • options available

-trlvl=int

Specifies a trace mode or no trace. The value of int must be 0, 1, 2, or 3. If an int value is not specified or if you specify a value not in the range, the trace turns off automatically. Each trlvl mode is distinct and does not include information from other trace modes.

0

specifies no trace.

1

traces direct connect creation, thread creation, and login operations.

2

traces file input/output operations and only displays if a function related to file input/output fails.

3

traces the invocation of hexecp.

-trace

Displays PEC-related trace messages.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/harvest-scm/14-0/installing/Configure-CA-Harvest-SCM/Configure-Broker-and-Server-Communication/Configure-the-Broker-and-Server-Communication-on-Windows.html (section titled “Agent Start Options on Windows”)

 

  • RTServer
    • logging settings go in %RTHOME%\standard\rtserver.cm
    • change in the rtserver.cm file requires restart to take effect
    • no option to dynamically turn on/off logging
    • log files found in folder specified in the settings
    • log file name format specified in the settings
    • logging is continuous and does not roll to a new log file
    • options available (For the setopt log* options change “UNKNOWN” to a valid folder and file name on the computer. The folder must already exist.)

setopt log_in_client

File to log incoming messages from RTclient processes

setopt log_out_client

File to log outgoing messages to RTclient processes

setopt log_in_server

File to log incoming messages from other RTServer processes

setopt log_out_server

File to log outgoing messages to other RTServer processes

setopt command_feedback

Have RTserver provide feedback on interactive commands executed

http://10.175.217.32:8090/display/IPSWiki/PECDocumentation

 

  • HDBSetup
    • Related logs found in %CA_SCM_HOME%\log
    • Logging is always on – no need to enable
    • To increase logging for “CR – Create Repository” or “UR – Upgrade Repository” add “-logging=5” to HServer.arg and restart HDBSetup
    • Log file names and contents:

HDBSetup.log

contains activity and error messages from hdbsetup

loadschema.log

contains database activity related to creating a new Harvest database (CR)

updateschema.log

contains database activity related to upgrading a Harvest database schema (UR)

enclog.log

contains any error messages related to creating an encrypted password file (EP)

enctemplog.log

contains any error messages related to creating an encrypted password file

lflog.log

contains any error messages related to loading the default forms (LF)

lplog.log

contains any error messages related to loading the default projects (LP)

 

  • ODBC

 

Client-Side

  • Command line utilities
    • Execution of a command line utility will normally write results to a log file rather than the console. Always check the log file to see the results of the command.
    • By default the log file will have the same name as the command with a “.log” file extension, and this file will be found in the current working directory (the folder you were in when you ran the command)
    • To override the name and/or location of the log file use the “-o” (output) or “-oa” (append output) option with the command and specify the path and name you want.
    • Additional tracing can be enabled on the “hci” (check in) and “hco” (check out) commands by adding the “-tr” option.
    • Exceptions:

hauthtst, hexecp,

hsigget,

hsigset,

hsql,

svrenc

Writes all results to the console rather than to a log file.

hrefresh

Log files will be named for each hrefresh job executed and will be found in the %CA_SCM_HOME%\log folder

hmvproj

Log files will be found in the current working directory.  Log file names will include the name of the project being moved.  Adding “-sql” to the command results in additional logging.

 

  • Workbench
    • The contents of the “Output Log” view are written to %USERPROFILE%\.cascm\workspace\.metadata\CASCM.log
    • Location of the CASCM.log file can be changed and logging level increased by going to Tools -> Preferences -> Logging
    • The other log file in that folder is named “.log” (only the file extension, no actual file name). This contains any java-related or Eclipse-related errors.

 

  • Administrator Tool
    • The “Results” tab in the tool will show any errors that happen. Normally a log file is not written.  This can be enabled on the Tools -> Options window in the “Settings” tab.

 

  • Harweb
    • Any error information for Harweb will be found in the log flies for the application server that hosts it. For example, for Apache Tomcat, check the localhost.log and catalina.log files in the <tomcat home>\log folder.

 

  • Eclipse Plugin
    • The contents of the “Output Log” view are written to %USERPROFILE%\eclipse-workspace\.metadata\CASCM.log
    • Location of the CASCM.log file can be changed and logging level increased by going to Window -> Preferences -> Team -> CA Harvest SCM -> Logging
    • The other log file in that folder is named “.log” (only the file extension, no actual file name). This contains any java-related or Eclipse-related errors.

 

  • Visual Studio Plugin
    • Log file location can be found on the Logging options windows. Go to Tools -> Options and navigate to Source Control.  Under “Plug-in Selection” make sure that “CA Harvest Software Change Manager” is selected, then click on “Logging”.  Location of the log file is there (and can be changed there), as well as setting debugging level and the maximum number of lines allowed in the log file.  After any changes, restart Visual Studio for the changes to take effect.