search cancel

CVE-2021-44228: Is CABI affected by the log4j zero day vulnerability?

book

Article ID: 230258

calendar_today

Updated On:

Products

CA Spectrum DX NetOps DX Unified Infrastructure Management (Nimsoft / UIM) CA Service Operations Insight (SOI)

Issue/Introduction

Apache Log4j2 <=2.14.1 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled

Environment

CABI 7.1.x, CABI 6.4.x

Resolution

CABI (all supported Spectrum versions) is not affected by this vulnerability.

Additional Information

As an additional way to check you can run the following command in Linux from CABI install folder

 

for i in $(find . 2>/dev/null | grep log4j | grep .jar); do echo $i; unzip -l $i 2>/dev/null | grep JndiLookup; done

 

You will see there are no files output that are vulnerable.

 

Jasper Server 7.9 and Jasper Studio 7.5  (not supported by Spectrum) are vulnerable, more information at this link

 

https://knowledge.broadcom.com/external/article?articleId=230331