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SpectroSERVER CONNECTION TO MLS CANNOT BE ESTABLISHED

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Article ID: 229893

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Updated On:

Products

CA Spectrum

Issue/Introduction

New users created in a 5 SS DSS, do not see 1 of the landscapes.

The landscape map run on this SS shows just itself and no DSS entries, while the landscape map on the MLS is correct.

This used to work and stopped.  

All hostrc, locrc and etc_host files are fully populated.

All ports are opened in the firewall between the MLS this SS which is the only 1 in another domain.

 

Environment

Release : 20.2

Component : Spectrum Core / SpectroSERVER

Cause

Locserve debug on both MLS and SS show the connection is refused by the SS on port 56063.


we ran a netstat from the SS to MLS on 56063 and get a blank screen with no prompt but no error. This is not a correct connect as we contrasted it with another SS to MLS and got back the connected user and a flashing prompt.  The networking team said it was connected like this as it shows no connection error but from a netstat on the MLS showed no connection on 56063 to this SS while we saw the other SS connected on that port. It seems like the SS is able to communicate with the MLS but then the MLS cannot communicate back and we never get the correct prompt. This matches with the errors in the logs that the problem is coming from the SS side.

We then tested with port 21 from the SS and got a connection refused from remote host error, while the same command from another SS showed a successful connection.

All of this was done outside of Spectrum so nothing in Spectrum caused these problems.  

Resolution

This is not a Spectrum issue and needs to be resolved by the networking team.