VIP Enterprise Gateway LDAP sync service not starting after 9.9.1 upgrade when an HTTP proxy is in use
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VIP Enterprise Gateway LDAP sync service not starting after 9.9.1 upgrade when an HTTP proxy is in use

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Article ID: 229826

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Updated On:

Products

VIP Service

Issue/Introduction

VIP Enterprise Gateway LDAP sync service will not start after upgrading to 9.9.1 upgrade when an HTTP proxy is in use. The VIP LDAP sync service.log error is java.net.UnknownHostException: userservices-auth.vip.symantec.com.

Cause

The VIP Enterprise Gateway may not communicate correctly with the HTTP Proxy configured in the VIP Enterprise Gateway console under Settings > HTTP Proxy Settings.

Resolution

Note: This hotfix should be applied only to VIP Enterprise Gateway 9.9.1.

  1. Download the attached VIP1464_HotFix and extract the contents to a temporary location (E.g., /opt/temp/ [Linux] or C:\temp [Windows]).
  2. Stop all VIP services from the VIP console, then stop the VIP Enterprise Gateway service.
  3. Create a backup of the following files:
    • <VIP EG Install folder>/server/webapps/vipconsole.war
    • <VIP EG Install folder>/server/ext/engine.jar
    • <VIP EG Install folder>/server/ext/restful.jar
  4. Delete jetty-0.0.0.0-8232-vipconsole.war-_vipegconsole-any- from the <VIP EG Install folder>/server/work directory.
  5. If the VIP SSP or My VIP is configured, delete jetty-0.0.0.0-8233-sspwebapp-_myvip-any- and jetty-0.0.0.0-8233-sspwebapp-_vipssp-any- from the <VIP EG Install folder>/IDP/services/SSP  directory.
  6. From the temporary directory the hotfix was extracted to step 1, copy the following files: 
    vipconsole.war to the <VIP EG Install folder>/server/webapps directory. 
    engine.jar to the <VIP EG Install folder>/server/ext directory.
    restful.jar to the <VIP EG Install folder>/server/ext directory.
  7. Restart the VIP Enterprise Gateway service.
  8. Log in to the VIP Enterprise Gateway Console and restart all required components.

Rolling back the hotfix:

If any issues are encountered after installing this hotfix, follow these steps to revert the changes: 

  1. Stop all VIP services from the VIP EG console, then stop the VIP Enterprise Gateway service.
  2. Delete jetty-0.0.0.0-8232-vipconsole.war-_vipegconsole-any- from the <VIP EG Install folder>/server/work directory.
  3. If the VIP SSP or My VIP is configured, delete jetty-0.0.0.0-8233-sspwebapp-_myvip-any- and jetty-0.0.0.0-8233-sspwebapp-_vipssp-any- from the <VIP EG Install folder>/IDP/services/SSP directory.
  4. Navigate to the location where you backed up the VIP Enterprise Gateway files during the installation of the hotfix and copy them back to the original location:
    vipconsole.war to the <VIP EG Install folder>/server/webapps directory. 
    engine.jar to the <VIP EG Install folder>/server/ext directory. 
    restful.jar to the <VIP EG Install folder>/server/ext directory.
  5. Restart the VIP Enterprise Gateway service.
  6. Log in to the VIP Enterprise Gateway Console and restart all required components.

Attachments

VIP1464_HotFix_1638823758773.zip get_app