Unable to import JIL through WCC
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Unable to import JIL through WCC

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Article ID: 229798

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

A user attempting to import a jil script via the WCC, is getting the following error. 

Unexpected problem connecting to Server
StatusCode: 400, URL: https://aews-example.test.examplecompany-example.org/AEWS

I confirmed I was able to import a jil script. I also confirmed via EEM permission check that the user should be able to import jobs to the environment. The environment is Open to all users to create jobs.  I had the user switch to Chrome browser, he was using Edge. I recycle the WCC services, app service and web service but that didn't help. 

He imported jobs 4 days earlier. I was also able to import jobs using a test ID that belongs to the same AD group. 

Environment

Release : 12.0

Component : WORKLOAD CONTROL CENTER

Cause

You only fill in the "Name" field on the ECLI if you are trying to export a job. In that case, you provide the name of the job to be exported.

If you are attempting to import a job you only fill in the "File name" which is the path and filename of the file that contains the jil.

In BOTH situations you fill in the "Server".

Errors will typically be further down in the Errors section.   

We used the jil file provided and saw the error the end user saw.

The reason for the error is the file contains control characters between the two jobs.

Resolution

There were/are two null characters, once removed the error went away and the jobs were imported in without further issue.