Appliances page shows 'An error occurred' after upgrade
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Appliances page shows 'An error occurred' after upgrade

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Article ID: 229669

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Updated On:

Products

Endpoint Detection and Response

Issue/Introduction

After upgrading to Endpoint Detection and Response (EDR) version 4.6.7/4.6.8/4.7.0, the appliance details is not showing on Settings> Appliances page with "An error occurred' message.

License Status is also missing on Settings> Global page under Licensing section with error "Failed to retrieve status"

Management Port section also shows "500 INTERNAL_SERVER_ERROR instead of default 443.

System Health status on EDR console shows "Symantec EDR is Critical" with these errors:

  • Unable to get license information
  • Error in retrieving component health status.

Environment

EDR version: 4.6.7, 4.6.8, 4.7.0-458

Cause

It is identified as a known issue when EDR 4.6.7/4.6.8 is directly upgraded from an older build prior to 4.6.5.

Resolution

Broadcom Engineering has resolved this issue in EDR version 4.7.0. Please update to EDR 4.7.0 to receive this fix. If you are unable to upgrade to EDR 4.7.0, use the workaround listed below.

Workaround for versions prior to EDR 4.7.0:

A fix for this issue is provided in atp-patch1-4.6.8-1. To install the patch when on SEDR 4.6.8, run the following command:

patch install atp-patch1-4.6.8-1

Note: Please contact Technical Support for a possible workaround on previous versions Or, if the issue is seen after 4.7.0 upgrade where the workaround was applied earlier.