search cancel

Creating New Widgets in 16.0 - Error message when using "Current User" as a Only Include filter

book

Article ID: 229524

calendar_today

Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

Creating New Widgets in 16.0 - Error message when using "Current User" as a Only Include filter

STEPS TO REPRODUCE: 

 

  1. Navigate to To Dos in the Modern UX
  2. Click on the Widgets icon (left of gear icon)
  3. Click Add Widgets
  4. Click New Widget
  5. Select Widget Type (any is fine)
  6. Fill out the mandatory fields, then in the Only Include items where... box, select Owner in the Add Filter dropdown, then select on the Current User, e.g Owner=Current User
  7. Click Create, then under My Widgets, click Add
  8. Confirm your new Widget appears, then refresh page/filter
  9. Expected: No error and filter result show correctly
  10. Actual: Error Toaster Message (sample): API-1006: The value'(@[email protected])' for Attribute 'owner' is not in expected format or is invalid.
  11. Error happens with any resource field with Current User as a filter option (Manager, Owner, custom resource attributes, etc.)

Expected Results:  No error and filter result show correctly

Actual Results: API-1006: The value'(@[email protected])' for Attribute 'owner' is not in expected format or is invalid.

Error happens with any resource field with Current User as a filter option (Manager, Owner, custom resource attributes, etc.)

 

Environment

Release : 16.0.0

Component : Clarity MUX UI Usability

Resolution

Defect id: DE63328 is FIXED in 16.0.2