sdgtw and ServiceNow integration
search cancel

sdgtw and ServiceNow integration

book

Article ID: 229448

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We are trying to configure sdgtw with ServiceNow. Alarms from the sdgtw are not showing up in ServiceNow.

Environment

  • Release: 20.4 +
  • Component: sdgtw

Cause

The sdgtw probe will only create incidents (or events if using sdgtw 2.35 or later) for alarms that are assigned to the user configured in the sdgtw probe, which is administrator by default. 

Activating a connection to the ServiceNow application in the sdgtw probe alone will not cause incidents to be created in ServiceNow, incidents needs to be assigned to a user.

Resolution

Either manually assign alarms to the required users, or, to automatically assign alarms to user accounts, you can use these steps:

  1. Create service desk rules in the sdgtw configuration, and route based on the "assigned_to" and value, then select the appropriate servicenow profile in the sdgtw configuration.
  2. Use/activate nas Auto Operator profile that assigns alarms to the user configured in the sdgtw probe.

 

In applying these settings, be sure to check the sdgtw probe techdocs:

Configure General Properties in the sdgtw probe (Broadcom documentation)

Especially check these two parameters:

  • CA UIM Users for Alarm Processing: specifies the users to whom the alarms are assigned. You can enter multiple users in a comma-delimited list. The probe creates a service desk incident only for alarms that are assigned to a user specified in this list. Leave this option blank to process alarms assigned to any user. Default: administrator
  • CA UIM User for Alarm Assignment: specifies the user to whom the alarm is assigned when the probe is unable to communicate with the service desk, hub, or the alarm server. Default: administrator
For the nas Auto-Operator profiles, check:
The nas Auto-Operator Tab (Broadcom nas probe documentation) 
 
 
 

Additional Information

You can also assign a service desk incident to a particular group depending on the alarm severity:

Configure Field Mapping for the sdgtw probe (Broadcom documentation) 

Please also check: Sdgtw: assign alarms to multiple groups using NAS Pre-processing rule (Broadcom KB article)