After installation Symantec Endpoint Security Agent it shows Communication Failure.
search cancel

After installation Symantec Endpoint Security Agent it shows Communication Failure.

book

Article ID: 229446

calendar_today

Updated On:

Products

Endpoint Security

Issue/Introduction

Symantec Endpoint Security (SES) get installed but Communication status shows Failed.

............................
  server connection    failed
LinuxInstaller: Error 4 running cd "/tmp/instKUtiCB"; ./installagent.sh
Oct 14 16:24:16 cloud-init[2428]: util.py[WARNING]: Failed running /var/lib/cloud/instance/scripts/part-001 [4]
Oct 14 16:24:16 cloud-init[2428]: cc_scripts_user.py[WARNING]: Failed to run module scripts-user (scripts in /var/lib/cloud/instance/scripts)
Oct 14 16:24:16 cloud-init[2428]: util.py[WARNING]: Running module scripts-user (<module 'cloudinit.config.cc_scripts_user' from '/usr/lib/python2.7/site-packages/cloudinit/config/cc_scripts_user.pyc'>) failed
Cloud-init v. 19.3-44.amzn2 finished at Thu, 14 Oct 2021 16:24:16 +0000. Datasource DataSourceEc2.  Up 218.78 seconds

Environment

Release : 14.3 RU2

 

Cause

Proxy is blocking the traffic.

Resolution

Configure the proxy in CAFConfig.ini

Steps:

1/ Stop the sep agent by running /usr/lib/symantec/stop.sh

2/ edit /etc/caf/CAFConfig.ini

[proxy-config]
proxy-mode=MANUAL
proxy-uri=http://proxy:3128/
proxy-username=                
proxy-password=                
proxy-CertAuthKeys=%PROXY_CERTAUTHKEYS%
proxy-host=proxy
proxy-port=3128
proxy-https-port=3128

3/ Save the file and start the agent with /usr/lib/symantec/start.sh

4/ Check connection status with /usr/lib/symantec/status.sh