A Dataset was Uncataloged after trying to do a Dataset Rename with CA Roscoe
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A Dataset was Uncataloged after trying to do a Dataset Rename with CA Roscoe

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Article ID: 22942

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Updated On:

Products

Roscoe

Issue/Introduction

A dataset was uncatalogued after trying to do a dataset rename with CA Roscoe


Environment

Release: 6.0
Component: ROSCOE

Cause

If you have insufficient authority to ALTER the dataset you may see messages such as IGD17061I INSUFFICIENT SECURITY AUTHORIZATION. Return code is 8; DIAGNOSTIC INFORMATION IS 04100800 when trying to rename it under CA ROSCOE and the request will be rejected. If you have the authority to uncatalog the dataset, but not the authority to rename it or catalog it, this can happen. This is as expected. However, this can leave the original dataset uncatalogued and unavailable to use.   

Resolution

Non-SMS datasets may be uncataloged when you try to rename them and do not have sufficient authority. This is not a CA Roscoe problem. Roscoe renames the dataset by uncataloging it, renaming it and cataloging it again.

To resolve this problem, review and adjust your security settings or use a DSAEXIT to prevent the problem.