Possible Indexing issue on DCI GUI, after clean-up
search cancel

Possible Indexing issue on DCI GUI, after clean-up

book

Article ID: 229379

calendar_today

Updated On:

Products

Dynamic Capacity Intelligence

Issue/Introduction

This past Saturday night we performed clean-up on the DCI zfs.  After the change the data was no longer in the zfs and had been moved to the backup/cleaned up .tar file.  The months expected were then removed from the drop down in the DCI GUI.  As of this morning, however, those months have reappeared in the drop down in the GUI.  The data is no longer in the zfs, however, and there is an error when selecting those months for viewing.  

Environment

Release : 2.0

Component : DYNAMIC CAPACITY INTELLIGENCE

Cause

When they cleaned out the ZFS the Policy-Index.xml was removed from the config directory but not the XML directory. DCI uses the XML directory as a backup. If a file is missing from the config but present in the XML DCI restores what it finds into the config. 

Resolution

If the file is not in either then it creates a new blank file on startup. 
Remove the policy-index.xml from both directories and restart the controller.

Additional Information

Still good ; can be made external