UIM - Latency QoS metrics not showing for Citrix machines
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UIM - Latency QoS metrics not showing for Citrix machines

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Article ID: 229278

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After getting the QoS metrics actually working, there seems to be several still not showing.

These are 

QOS_DISK_LATENCY
QOS_DISK_READ_LATENCY
QOS_DISK_WRITE_LATENCY

Check already done on release notes
https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/cdm-cpu-disk-memory-performance-monitoring/cdm-cpu-disk-memory-performance-monitoring-release-notes.html

Confirmation already made on sysstat package being installed. (Linux and Unix platforms)
(Example test machine was a Redhat server. Check was made for sysstat which exists and shows output from sar -n DEV.)

"SYSSTAT package is running and test the command sar -n DEV.".

Environment

Release : 20.3

Component : UIM - CDM WITH IOSTAT

Cause

The CDM probe to be able to monitor the THROUGHPUT (rwx,QOS_DISK_READ_THROUGHPUT, QOS_DISK_WRITE_THROUGHPUT, QOS_DISK_TOTAL_THROUGHPUT) 
metrics will execute the following command [fdisk -l | awk '/Disk/{print$2}'] 
and use the command's output to monitor.

In this case the probe is not able to execute the command because the fdisk is not in the default folder wich is /usr/sbin and in
in the customer's environment, this probe is available in /sbin.

Resolution

Edit the environment variable in controller probe for the path environment variable.

1- Verify if fdisk command is available in /usr/sbin.
2- If the command is not there, we need to find where this command is available.
3- if we find the fdisk command in other than /usr/sbin then the Path environment variable in robot.cfg needs
to be appended with that path
4- Reboot the robot.
5- I will successfully start