After a non root install the Secure Domain Connector is not listening on port 6844
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After a non root install the Secure Domain Connector is not listening on port 6844

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Article ID: 229268

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Updated On:

Products

CA Spectrum

Issue/Introduction

I have a SPECTRUM 21.2.1 installation where I'm trying to setup a SDM environment as a non root install.

After the installation of the SDC was successful, we are seeing the following in the SDM log on the SDM server.

 

Tue Nov 16 16:03:30 2021: WARNING:  Could not connect to xx.x.x.x:6844
Tue Nov 16 16:03:30 2021: WARNING:  Socket error: 111
Tue Nov 16 16:03:35 2021: WARNING:  Could not connect to xx.x.x.x:6844
Tue Nov 16 16:03:35 2021: WARNING:  Socket error: 111
Tue Nov 16 16:03:36 2021: WARNING:  Could not connect to xx.x.x.x:6844
Tue Nov 16 16:03:36 2021: WARNING:  Socket error: 111

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Ports are opened between the SDM and the SDC, on default port 6844. SdmConnector process is running, as I can see its process in the processes list, but I cannot see any opened port 6844 on the local machine.

 

 

Environment

Release : 21.2.x  Red Hat Linux  Non-Root install

Component :SPCAPP  SDM / SDC

Cause

 CAPKI could not startup because /opt/CA/SharedComponents is owned by root

Resolution

Changed the directory  /opt/CA/SharedComponents from root to the nonroot SDC Install owner and group on the SDC server.

This allowed for CAPKI to be initialized upon SDC startup which was the reason for the Socket error: 111.

Additional Information

Further Troubleshooting steps can be found here

 

https://knowledge.broadcom.com/external/article/188338/setting-up-sdc-as-nonroot-user.html