Unable to open spectrum oneClick after adding an LDAP SSL
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Unable to open spectrum oneClick after adding an LDAP SSL

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Article ID: 229267

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Updated On:

Products

CA Spectrum

Issue/Introduction

Unable to open spectrum one click after adding LDAP SSL certificate and restarting tomcat.

Environment

Release : 10.4.1

Component :

Cause

After importing an SSL certificate to enable LDAP SSL and restarting tomcat, they could no longer access OneClick. The tomcat log showed problems to start.

Resolution

The tomcat log showed no error but tomcat was not starting. To get the system back online, we removed the LDAP cert from the keystore via command line and restarted tomcat and saw bind errors in the log.  We restarted processd and tomcat came back up and we could log in.

keytool -delete  -alias LDAP  -keystore ${keystore.file} 

We restarted processd and OneClick came up.

Additional Information

The user accessing OneClick was not a superuser so if the cert caused a problem for LDAP, then only superusers can access it.