OBS units are not visible when resources are not associated with it
search cancel

OBS units are not visible when resources are not associated with it

book

Article ID: 22913

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The OBS Browse is not working. Resources are not showing as attached to any OBS in the system, which is preventing functional use of the Resource and Resource Planning pages for viewing and managing resources and their allocations, etc. The OBS is associated with the Resource Object and Resources have an OBS Unit saved on their profile. So why is the lookup saying there are no resources attached to any OBSs?  We also tried to browse for a Resource OBS Unit on the Resource Planning Portlets and it has the same message. This is also happening for Project OBS Browse.

Steps to Reproduce for Resource Browse:

  1. Navigate to the Resource List
  2. Click on the browse icon to Filter for Resource OBS - Window pops up with error message:
    "You cannot select OBS units because no resources are attached to any OBSs"

Steps to Reproduce for Project Browse:

  1. Navigate to the Project List
  2. Click on the browse icon to Filter for Project  OBS - Window pops up with error message:
    "You cannot select OBS units because no projects are attached to any OBSs"

Cause

This implementation has only Financial OBS structures defined in Administration. The Financial Department OBS is associated with the Project and Resource Objects. The implementation does not have non-financial OBS definitions. We checked the Financial Processing page and found that the option to 'Hide Financial OBS' was enabled. When checked, Department and Location OBS will not be displayed in certain OBS Browses. Because there are only financial OBS units, the message is generated.

Resolution

Remove the option to Hide Financial OBS

  1. Login as an administrator user 
  2. Administration, Financial Management: Processing 
  3. Uncheck the box for 'Hide Financial OBS' 
  4. Click 'Save' button 
  5. Restart Application Services to load the OBS Lookups  (Note: For SaaS customers, please contact CA Support to have a task created to schedule the restart of app services.)

Alternatively, if you do not want to use Financial OBS Units for filtering throughout the application, create a non-financial OBS and associate with the appropriate objects.