search cancel

"Dependency not found" error when update UIM robot

book

Article ID: 229080

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Trying to update the robot_update version 9.20 but getting the error "Dependency not found" for robot update. Robot version -9.20 

Environment

Release : 20.3

Component : UIM - ROBOT_EXE

Cause

vcredist_x86 and vcredist_x64 were not in the archive of the remote hub

Resolution

1. Log in to the remote hub where the robots with the issue belong to.

2. Download the following packages and add them to your local archive: 

vcredist_x64 - http://support.nimsoft.com/Files/Archive/00457/vs2017_vcredist_x64_zip-1.0.2.zip

vcredist_x86 - http://support.nimsoft.com/Files/Archive/00458/vs2017_vcredist_x86_zip-1.0.2.zip

3. Make sure the robot_update in the archive of the remote hub is a compatible version, for example, robot_update 9.33

4. You should be able to update the robots to the latest version. 

Attachments