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Why are we seeing PERCENT ERRORS THRESHOLD EXCEEDED on the Interface alarm and clear at the same second?

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Article ID: 228884

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Updated On:

Products

CA Spectrum

Issue/Introduction

We have issue on the two devices, where we are getting alarms and events generated on the interface of the particular device as PERCENT ERRORS THRESHOLD EXCEEDED. 

We have checked the events of the device and found there is some abnormal issues on the respective interface. The alarm is getting triggered when the threshold value is exceeded and getting cleared once when the percentage of packets with errors drops below the reset value which is happening at the same second.

We have requested the network team to check any errors on the interface but they are saying no errors found on the interface or see any issues in switch and port level.

 

 

 

Cause

Attribute DURATION_ERR (0x12be5)  set to same value as polling.

Environment

Release : 10.4.x / 21.2.x

Component :SPCAEM

Resolution

As alarms are being created and cleared during the same second and poll cycle.  Therefore we need to change attribute DURATION_ERR (0x12be5) to a higher value that is not evenly divisible by your polling.  I.E. if polling is 300, change this to 615 this will force the polling to be on a different cycle then the threshold alarm.