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Cannot connect to DX Netops Virtual Network Assurance (VNA) after installation

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Article ID: 228860

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Updated On:

Products

CA Virtual Network Assurance DX NetOps CA Performance Management - Usage and Administration CA Spectrum

Issue/Introduction

After installation of DX Netops Virtual Network Assurance, cannot connect to port 8080 or 9990

Cause

Firewall or other intermediate network issue preventing connection to the ports.

Environment

Release : 21.2

Component :

Resolution

To verify if a firewall/network issue is preventing the connection to DX Netops Virtual Network Assurance (VNA) we can run a simple CURL command as follows:

1) From the server itself using the loopback:

curl -u admin:PASSWORD  -X GET --header 'Accept:text/plain' http://127.0.0.1:8080/vna/rest/v1/admin/ping
Version: 21.2.1-RELEASE Build: 129

Where PASSWORD is the VNA admin user password chosen during installation:

Example with output (the version returned will vary)

curl -u admin:admin  -X GET --header 'Accept:text/plain' http://127.0.0.1:8080/vna/rest/v1/admin/ping
Version: 21.2.1-RELEASE Build: 129

2) Run the same command remotely from the server you are having issues connecting from.
    If you do not get the same response or any response, this would indicate that a firewall or
    another intermediate network issue is preventing connection to the ports.