search cancel

PAM-CM-4075 Error When Using SCIM API Calls

book

Article ID: 228800

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

While using the API calls on 4.0.0 or 4.0.1, the following error occurs when the SCIM-related API is used. It happens for any API call within /cspm/ext/rest, anything within /api.php/v1/ is successful.

"PAM-CM-4075: Error processing request. Please contact Administrator."

In the session logs, the following messages are observed at the same time.

10/6/2021 20:07 test_scim-12345 login PAM-CMN-0902: To login you have to accept the terms of the license.
10/6/2021 20:07 test_scim-12345 login PAM-CMN-0902: To login you have to accept the terms of the license.
10/6/2021 20:07 test_scim-12345 login PAM-CMN-0902: To login you have to accept the terms of the license.

Cause

The PAM-CMN-0902 error occurs when the license warning has been enabled under global settings and "User Must Accept License" is checked. When this setting was disabled, the API calls started working again.

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=NuT0lbV4fgvYmF+4Gp2zfQ==

Environment

Privileged Access Manager 4.0.0 or 4.0.1

Resolution

This issue is addressed with defect DE517268 and will be fixed in the 4.0.2 and 4.1.0 releases. As a workaround, please go to Global Settings, click the Warnings tab, and un-check the box for User Must Accept License.