search cancel

Invalid column name 'GITHASH' while CheckIn

book

Article ID: 228765

calendar_today

Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

A problem is reported while CheckIn items after upgrading to SCM Harvest 14.x

---------- Begin  <CheckIn Items>  Process ---------------

E03020003: Database error [Microsoft][ODBC Driver 13 for SQL Server][SQL Server]Invalid column name 'GITHASH'.

SQLSTATE=S0022.

I00060079: Check in summary: Total: 1; Success: 0; Failed: 0; Not Processed: 1.

E03060019: Process Execute failed. Process Name: CheckIn Items.

---------- End  <CheckIn Items>  Process ---------------

 

Cause

The MS SQL Server Database patch was not installed or not properly installed.

Environment

Harvest SCM 14.x

Resolution

When applying the v14.0.1 patch, there is a DB patch that needs to be applied along with it.  

On the “Install CA Harvest SCM 14.0.1” page, there’s a section “Microsoft SQL Server Database” that describes how to run the script that updates the database.
https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/harvest-scm/14-0/installing/Install-CA-Harvest-SCM-14-0-1.html

Microsoft SQL Server Database

Perform the following steps after installing CA Harvest SCM 14.0.1 on Microsoft SQL Server Database:

- Navigate to the %CA_SCM_HOME%\Database folder.
- Run the Models_SQLServer_V1401Patch.sql file.
- The required table to be used with V14.0.1 is created.

Sample Formulation
Osql –d <database name> -i  <sqlfile> –U <user name> -P <user password> -e –b –o output.log

If this is still not working, please use the following procedure:

- Open SQL Server Management Studio and click “Connect”
- Select File -> Open -> File
- Navigate to %CA_SCM_HOME%\Database folder, select file “Models_SQLServer_V1401Patch.sql” and click “Open”
- Ensure the “harvest” database is selected instead of “master” and click “Execute”.