search cancel

Autosys Upgrade Assistant does not recognize 4.5.1 DB

book

Article ID: 228642

calendar_today

Updated On:

Products

CA Workload Automation AE

Issue/Introduction

Here is the QS1 instance which is the source DB I am trying to connect using AUA:

# autoflags -a
G2 LINUX SYB 4.5 1 c1b499e0 d46129-002.dc.gs.com
[email protected]:/opt/sybase/openclient <QS1>
# autorep -x
4.5.1.G2
[email protected]:/opt/sybase/openclient <QS1>
# echo $AUTOSERV
QS1

Please see the error in the screenshot below:

Environment

Release : 4.5

Component :

Resolution

Back when there was 4.5.0 and 4.5.1 some of the patches could be applied to either version and essentially bring them up to the same levels.  I suspect the system you are dealing with was base 4.5.0 and then patched to G2 (incremental 2).  There were no sql updates in place that changed the alamode version entry from 4.5.0 to 4.5.1.
You can manually update that single db entry and then AUA will proceed.

update alamode set str_val = '4.5.1' where type = 'VERSION';