Cannot start IM connector from IP
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Cannot start IM connector from IP

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Article ID: 228627

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Updated On:

Products

CA Identity Suite

Issue/Introduction

After upgrading from 14.1 to 14.3 CP2 the connector from the portal to IM fails with the following error appears:

Calling webservices Testing connectivity and configuration failed

 

Environment

Release : 14.3

Component : IdentityMinder(Identity Manager)

Cause

Wrong library files are deployed.

Resolution

The most common reason for this issue is discussed in the knowledge article below:

https://knowledge.broadcom.com/external/article?articleId=144871

However, a scenario was identified by the Services team where two versions of the Jersey libraries were deployed in IM.  Specifically, jersey-*-1.17.1.jar and jersey-*.jar.  This stopped the connector from starting as expected.  After removing 1.17.1 files, the system worked as expected.

Additional Information

IM (Identity Manager) 14.3 GA (General Availability) and its CPs (Cumulative Patches) ship with the jersey-*jar files.  The jersey-*-1.17.1 jar files are from 14.1.