CA 11 won't restart S CAL7 IEFC612I PROCEDURE CAL7 WAS NOT FOUND
search cancel

CA 11 won't restart S CAL7 IEFC612I PROCEDURE CAL7 WAS NOT FOUND

book

Article ID: 228616

calendar_today

Updated On:

Products

DATACOM - AD CA-11

Issue/Introduction

CA 11 was shut down to upgrade to Datacom 15.1, now the CA 11 task won't restart: 

S CAL7

IEFC612I   PROCEDURE CAL7 WAS NOT FOUND

 

Environment

Release : 15.1

Component :

Cause

This occurs when the CA 11 sybsystem name is also CAL7. The IEFC612I message documentation explains why the error occurs:

If the name of the procedure being started is the same as the name of a subsystem, the procedure will be started under the Master Subsystem (MSTR). Since the only procedure libraries available to the Master Subsystem are those specified in the MSTJCLxx's IEFPDSI data set, any procedures being started which are defined in the job entry subsystem's PROC00 data set, but not in the MSTJXLxx IEFPDSI data set will be unavailable and will therefore receive message IEFC612I.

 

Resolution

Use this command instead to start CA 11:

S CAL7,SUB=JES2

There is a note in the CAL7SAMP(AL7CAL7) member that says to use that command to start CA 11:

       CA-11 DBAS SUBSYSTEM PROCEDURE                            
                                                                 
 IF THE SUBSYSTEM NAME IS THE SAME AS THE PROC NAME, YOU CAN     
 START THIS STARTED TASK WITH THIS COMMAND TO GET A JOB LOG FOR  
 JES2 CUSTOMERS WHO START CAL7 AFTER JES2 COMES UP:              
                                                                 
     S CAL7,SUB=JES2