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Spectrum is creating Duplicate SNOW Incidents for Alarms.

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Article ID: 228546

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Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum is creating Duplicate SNOW Incidents for Alarms.

Cause

  • SNOW Misconfiguration

Environment

Release : 20.x

Component : Spectrum Integrations

Resolution

  • Check the Tomcat log (stdout.log\catalina.out).
  • Every time Spectrum creates a ticket via NIM it will print a Creating ticket Event:

  • If  there is only one instance of Creating ticket per alarm id then Spectrum is NOT creating duplicates.
  • Check the log for any Error\Return codes from SNOW:

Nov 12, 2021 14:08:11.135 (AlarmNotifier) (SDIntegration) - Creating ticket: problemType='', endUserId='' asset='', alarmId='618ec9a1-22ea-1b3b-02af-0080108c030a'
Nov 12, 2021 14:08:17.342 - Error occurred while attempting to create a ticket in Service Desk. java.lang.Exception: {"Error":{"ErrorCode":154,"ErrorMessage":"Exception occurred during operation insert","DetailErrorMessage":"Error executing business rule 'CG Spectrum Set CI and Priority fields'","HTTPResponseCode":"INTERNAL_SERVER_ERROR","HTTPResponseCodeValue":500}}

As an Example: This rule is a SNOW Business Rule that was misconfigured:  Error executing business rule 'CG Spectrum Set CI and Priority fields'

 

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