search cancel

ITPAM Agent installation fails with error "java.lang.UnsupportedClassVersionError: Unsupported major.minor version 52.0"

book

Article ID: 228511

calendar_today

Updated On:

Products

CA Process Automation Base

Issue/Introduction

ITPAM Agent installation fails with error "Unable to launch the application"

In the Details tab, the actual error is shown as:
Error: java.lang.UnsupportedClassVersionError: org/mozilla/javascript/ScriptableObject : Unsupported major.minor version 52.0

Environment

Release : 4.3.05

Component : Process Automation

Cause

The issue is because of Java version mismatch between the Orchestrator server and Agent server.
Unsupported major.minor version 52.0 comes when you are trying to run an application developed using Java 1.8 compiler into a lower JRE version e.g. JRE 1.7 or JRE 1.6.

Resolution

To fix this error install the Java version 8 and run the installation.

Additional Information

In this case, Orchestrator Java version is 1.8.0_162 so installed same Java version on the Agent server as well.

 

Attachments