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AgentName resolution failing after upgrade

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Article ID: 228487

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Updated On:

Products

SITEMINDER CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder)

Issue/Introduction

After doing a parallel upgrade from 12.7 to 12.8.5, the Access Gateway web agent is unable to correctly resolve the agentname for incoming requests, resulting in all requests using to the defaultagentname.  The agentname is defined by IP, and that IP matches the only IP address configured for the AG system.   The virtual host to which the agent is bound contains no IP address in the server.conf.

Cause

UseServerRequestIp ACO setting was enabled for this agent while it was not enabled for the 12.7 agent, and thus the difference in behavior.

Environment

Release : 12.8.x

Component : Access Gateway

Resolution

UseServerRequestIp ACO parameter was set to yes for this agent.  Once set to no, agentname resolution began working as expected.