search cancel

SSO SDK version container gateway

book

Article ID: 228372

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

Deploying container gateway version 10.1 the current SSO SDK on this container is 12.8.3 this version does not contain a needed fix for support migration mode encryption

The docker container needs have SSO SDK updated to fix migration mode fix in 12.52,09 in at least version: 12.8.05

 

Environment

Release : 10.1

Component : API GATEWAY

Resolution

Upload container image with SSO SDK 12.8.06 included 

This fix will be include in 10.1 CR1 also expected in release 10.0 CR 5  

 

 

 

Additional Information

How to verify - access container exec 

# docker ps

CONTAINER ID        IMAGE                                                                                                                                          COMMAND                  CREATED             STATUS                   PORTS                                                                    NAMES

31c060be2ec9        apim-docker-dev-local.artifactory-lvn.broadcom.net/apim-gateway/gateway-enterprise:hotfix-DE514641_SiteMinder_SDK_Upgrade_12.8.06_GW10.1-358   "/usr/local/bin/dumb…"   2 minutes ago       Up 2 minutes (healthy)   0.0.0.0:8080->8080/tcp, 0.0.0.0:8443->8443/tcp, 0.0.0.0:9443->9443/tcp   docker10_api-gateway_1

#  docker exec -it 31c060be2ec9 /bin/bash

bash-4.2$ cd /opt/CA/sdk/install_config_info

bash-4.2$ more ca-sdk-version.info

ProductName=SiteMinder SDK

FullVersion=12.80.600.2649

Location=/opt/CA/sdk