One user on 12.1 Web Viewer is unable to login but is OK to login on V11.5
search cancel

One user on 12.1 Web Viewer is unable to login but is OK to login on V11.5

book

Article ID: 228272

calendar_today

Updated On:

Products

Output Management Web Viewer

Issue/Introduction

We're seeing some messages for a user on 12.1 Web Viewer when unable login, yet they login successfully on 11.5 Web Viewer.

The message in the DRAS task for V12.1 is ACF01044 PASSWORD PHRASE NOT SET FOR LOGONID UserID
The same "UserID" logs into the same DRAS task successfully from 11.5 Web Viewer.

 

Environment

Release : 12.1

Component : CA OUTPUT MANAGEMENT WEB VIEWER FOR ALL PLATFORMS

Cause

The user had changed their password to one with 9 characters (how exactly, is unknown), but somehow ACF2 was reading it coming to DRAS as an attempt to send a Passphrase, which let to the DRAS Log showing:  ACF01044 PASSWORD PHRASE NOT SET FOR LOGONID USR2ID2

Resolution

When the user changed to an 8 character password, they were able to log into Web Viewer and work normally.  In order to stop this scenario from recurring, the Web Viewer administrator should go to the Web Viewer Administration tab, Repository, select the repository, check the "Passphrase supported by LPAR" checkbox and click Update. Then uncheck the same checkbox and click update again.

Explanation:  If it is never set, the database will contain a NULL value, which allows Web Viewer to send the more than 8 characters when the user attempts to login. By checking the checkbox, updating it, and then unchecking it and updating it again, the database will no longer contain a NULL value for the parameter, and subsequently Web Viewer will truncate any password value greater than 8 characters.