Error: StopService('AeXNSClientLauncher'): Failed to open Service Control Manager, error 0x0000045B (A system shutdown is in progress)
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Error: StopService('AeXNSClientLauncher'): Failed to open Service Control Manager, error 0x0000045B (A system shutdown is in progress)

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Article ID: 228268

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Updated On:

Products

Client Management Suite

Issue/Introduction

Computers fail to image after reboot to production and It appears that the agent is trying to re-install after imaging but fails because the computer is rebooting.

What happens is that Ghost and DeployAnywhere run successfully, and the computer reboots to Windows, but the agent does not start correctly in Windows and the computer does not check in, so the job fails and any subsequent tasks do not run.

This works for most computer makes/models and is only being seen on Lenovo L540 and T560.

The following is seen on the computers:

2021-11-11 08:45:52 P:1932   T:2092   *ERRR AeXUtility: StopService('AeXNSClientLauncher'): Failed to open Service Control Manager, error 0x0000045B (A system shutdown is in progress)
2021-11-11 08:45:52 P:1932   T:2092   *ERRR Installer: StopService action failed with reason: A system shutdown is in progress (0x0000045B) for service: AeXNSClientLauncher
2021-11-11 08:45:52 P:1932   T:2092   *ERRR CoreUtil: Upgrade failed. Error message: Failed to run action: StopCoreAgent
2021-11-11 08:45:52 P:1932   T:2092    INFO Installer: Core Agent Re-Installation Ended

Environment

DS 8.5 RU4

Cause

The Symantec Agent was reinstalling or upgrading at the end of the imaging process

Resolution

Unchecking the "Upgrade Symantec Management Agent to the latest version" as shown here allowed the imaging process to complete: