CA Identity Portal Wildfly Service Does Not Stop Gracefully
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CA Identity Portal Wildfly Service Does Not Stop Gracefully

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Article ID: 228067

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Updated On:

Products

CA Identity Suite CA Identity Portal

Issue/Introduction

CA Identity Portal version 14.4. Unable to stop the WildFly service gracefully through the Windows Services tab and instead need to stop java.exe in order to stop the WildFly service.

https://api-broadcom-ca-user.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=41BK3HzneLewtlkORUuGaQ==

Error 1053: the Service did not respond to the start or control request in a timely fashion.

Found that the OpenJDK Java service we are using to run WildFly is taking up a lot of CPU resources. In the Windows Task Manager, we have observed that the Java service causes the CPU usage to be 100%.

Environment

Release : 14.4 Standalone

Component : Identity Portal 

Cause

Found client has 32GB or RAM.  Min and max heap size was set to 16GBmin and 25GBmax.  Set to 8192min and 8192max.  

Resolution

standalone.conf.bat in order to reconfigure JVM.

Before:

set "JAVA_OPTS=-Xms16384M -Xmx24576M -XX:MetaspaceSize=96M -XX:MaxMetaspaceSize=256m -XX:MaxPermSize=1024M"

After:

set "JAVA_OPTS=-Xms8192M -Xmx8192M -XX:+UseG1GC -XX:+UseStringDeduplication -XX:+UseCompressedOops -XX:MetaspaceSize=96M -XX:MaxMetaspaceSize=256m -XX:MaxPermSize=1024M"

Even though client had high load, lowing the java heap actually made Portal more efficient as it was not stressing the I/O and trying to use all the RAM at once.  IP service now started and stopped properly.