Issues Accessing Visualizer from Workstation
search cancel

Issues Accessing Visualizer from Workstation

book

Article ID: 227829

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Customer recently implemented Visualizer with HTTPS/SSL.

Administrators are able to launch Visualizer on the Application Server.

Users are unable to launch Visualizer from their workstations.

pdm_tomcat_VIZ.log from SDM log folder contains the following:

Nov 07, 2021 3:18:59 PM org.apache.coyote.http11.Http11Processor service
INFO: Error parsing HTTP request header
 Note: further occurrences of HTTP request parsing errors will be logged at DEBUG level.
java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
 at org.apache.coyote.http11.Http11InputBuffer.parseRequestLine(Http11InputBuffer.java:432)
 at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:502)
 at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:65)
 at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:818)
 at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1623)
 at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
 at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
 at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
 at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
 at java.base/java.lang.Thread.run(Thread.java:834)

Environment

Release : 17.3

Component : CA CMDB VISUALIZER

Visualizer configured on Application Server

Cause

Server.xml file not configured

Resolution

C:\Program Files (x86)\CA\Service Desk Manager\bopcfg\www\CATALINA_BASE_VIZ\conf\Server.xml was not configured to use SSL

The steps to configure SSL are detailed here for 17.3 (link) and 17.4 (link)