The first AD authentication attempt consistently fails after restarting the TDM Portal service
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The first AD authentication attempt consistently fails after restarting the TDM Portal service

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Article ID: 227813

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Every time the TDM Portal Service is restarted, the first AD authentication attempt always fails. Once the connection is established the problem is not seen, until the TDM Portal service is restarted,

 

 

Environment

TDM 4.9.1+

Cause

The problem was caused by the "Referral Strategy" configuration used in the AD/LDAP configuration for TDM Portal. The Referral Strategy specifies whether you want to Follow or Ignore the reference to another source if the user in one group is also a part of the other group. Select the respective option from the drop-down list.

Initially the "Referral Strategy" configuration was set to "Ignore":

Resolution

Changing the "Referral Strategy" to "Follow" resolved the issue.

 

Additional Information

For more information, see LDAP Integration with the CA TDM Portal

Attachments

ReferralStrategyFollow_1636402270037.png get_app